Monday, March 10, 2008

The Common Car Amplifier Problems and The Way To Solve It.

Many car amplifiers are incorrectly diagnosed and sent in for repair/returned because of incorrect hookup. Sometimes the amp itself really is at fault. Here are a few common problems and what can be done to troubleshoot, as well as fix them (my fixes are the most common. They are not definitive in any way. Your amplifier could have a completley different problem, though it is unlikely.

Problem: Amplifier does not turn on.

Solution: Rule number one in amplifier hook up is to make sure the amplfier has a good ground. This means that it is secured to bare metal that is clean, rust-free, and tight.

Is the remote wire hooked up? Be sure it is, and that it is hooked up to the blue wire w/white stripe coming from the head unit, NOT the solid blue wire.

After that point, if the problem still exists, you’re probably looking at bad parts in the PSU (power supply unit). The majority of the time, it’s because mosfets are blown. It is never a bad idea to try hooking up the amplifier in a different car or taking it in to be tested just to be sure. Sometimes you can open the amp up and find physically fried components. For space constraints, I’ll leave it at that.

Problem: Amplifier goes into protect.

Solution: This can be caused by too low of an impedance from the way the speakers are wired, and sometimes a poor charging system (if the amp goes into protect when the volume is turned up).

Otherwise, it’s likely that the output transistors failed. That’s the most common cause for an amplifier to go into protection. With no power applied to the amp, grab a multimeter, set it to ohms, and measure the resistance between the output transistors terminals. You should find none that have anything close to zero ohms between any of the terminals. If you find one or more that read ~0 ohms between therminals, they need to be removed from the circuit and checked. If you have several in parallel, it may seem as though the entire group shorted, but generally one fails and the others are OK. Of course, when you have one defective transistor in a group of parallel transistors, you must replace all of the transistors in that group. Open or broken emitter resistors can cause an amp to go into protect. If you don’t find any shorted outputs, make sure there are no broken terminals on the emitter resistors

Problem: Amplifier is getting very hot/shutting down.

Solution: This is normally a result of the gains/input sensitivity being set too high. In addition, a lower impedance than the amp is rated for can cause this problem (and in the case of a lower impedance, it can cause permanent damage). Make sure your gain isn’t turned up all the way, and that there is at least a bit of dial space between the max and where it is currently set. Be sure the speakers are wired to an impedance the amplifier can handle, and that the speakers are in good working order.

If the above have been met and the amplifier is still overheating, the best thing to do is add external cooling fans. PC fans work great, and I suggest getting the 3-5″ models. They can be hard wired to the car’s electrical system and a simple switch can be wired inline to turn them on and off.

Problem: Amplifier’s volume turns down.

Solution: Many new amplifiers have protection circuitry that will limit the volume if they begin to get too hot. In this case, you would want to refer to the above problem for the solution.

Problem: Amplifier keeps blowing fuses.

Solution: This is usually caused by shorted output devices or power supply rectifiers. I’ll refer you to the solution for the amplifier going into protect as it is basically the same thing, and is usually the root of the problem 95% of the time. Beyond that, it could be a shorted filter cap, some sort of short across the power rails, some short across the output, or shorts across the primary,. And, let’s not forget loose hardware (any missing screws or nuts? A loose one under a pc board can short out most anything.)

Problem: Amplifier has intermittent or no sound.

Solution: This basically comes down to two troubleshooting steps:

1. Try connecting a portable CD player to the RCA inputs (via headphone to RCA cable) and see if you get sound. If you do get sound, then the RCA cable from the head unit could be bad, or the head unit’s RCA outputs could be fried or not turned on.

2. Try hooking up a known-working speaker. If the speaker works, then chances are the ones you have are blown. Press down on the speaker cone of the likely blown speaker, and if it scratches, it’s definitely bad.

Again, if that doesn’t solve the problem, there is definitely a problem with the amplifier itself. Usually one of the output devices is to blame (seeing a consistency here?).

Problem: There is alternator whine or noise through the speakers.

Solution: This is another classic example of a bad ground. You must have a good ground connection. If the ground has been checked and is not the problem, a noise suppresor might be necessary.